iulian

Chart image quality has decreased (blurred) in version 3.12.1

6 posts in this topic

Chart image quality in version 3.12.1 has decreased significantly.

Previously we were using 3.9.0 and the quality of the generated charts was good. After upgrade, we have noticed that charts quality went down significantly. Column bar edges, for example, is not sharp, but blurry. I have attached a screenshot with a Fiddle. The example is the one you have in your website.

After a investigation we have found the cause to be the x and y values of the <rect /> that are not integers. When the numbers are integers, the edges look fine. See attached image.

We have noticed that this happens on some resolutions only. From our experience, you will be able to reproduce the issue on 1920x1080 resolutions.

2017-07-18_10-58-53.png

Edited by iulian
Added info on how to reproduce the issue.

Share this post


Link to post
Share on other sites

Hi,

On investigating the problem I found that on both the version the x and y values of the rect element are in decimal, also the chart quality seems to be fine from my end, please check the image for details

 

rect.png

Share this post


Link to post
Share on other sites

Ayan, it is happening only on 1920 x 1080 resolution. If you zoom the image I uploaded, the difference in quality is visible. I am using the example posted on your website.

I have to mention that at the moment I am using a 2560 x 1600 resolution and I am not seeing the problem. If I change to 1920 x 1080 I can see the problem.

Edited by iulian

Share this post


Link to post
Share on other sites

Any update on this?

Guys, is your software, I am trying to help by reporting the issue. At least reply!

Share this post


Link to post
Share on other sites

Hi,

We checked the sample on 1920 x 1080 resolution and the chart quality seems to be fine at our end.

Share this post


Link to post
Share on other sites

Thanks Ayan... I don't know what else to say. Is visible on our end. It was detected by automated tests as they were failing. Then we were able to see the same problem with the example on your page, on different computers.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now