flavio00

Members
  • Content count

    7
  • Joined

  • Last visited

Posts posted by flavio00


  1. Hey there!

     

    Im using fusionCharts to show some information of my database. But when I try to generate ASP.NET chart (RenderChartHTML) in IE, my title (caption) and subtitled (SubCaption) are being presented with "..." at the end, without displaying the full sentence. But when I generate in Google Chrome, everything is OK. I need to generate these graphics in IE, I can not use another browser.

     

    This is FusionCharts.RenderChartHTML method:

     

     public static string RenderChartHTML(string chartSWF, string strURL, string strXML, string chartId, string chartWidth, string chartHeight, bool debugMode)
            {
                StringBuilder builder = new StringBuilder();
                string str = string.Empty;
                if (strXML.Length == 0)
                {
                    str = string.Format("&chartWidth={0}&chartHeight={1}&debugMode={2}&dataURL={3}", new object[] { chartWidth, chartHeight, boolToNum(debugMode), strURL });
                }
                else
                {
                    str = string.Format("&chartWidth={0}&chartHeight={1}&debugMode={2}&dataXML={3}", new object[] { chartWidth, chartHeight, boolToNum(debugMode), strXML });
                }
                builder.AppendFormat("<!-- START Code Block for Chart {0} -->" + Environment.NewLine, chartId);
                builder.AppendFormat("<object classid=\"clsid:d27cdb6e-ae6d-11cf-96b8-444553540000\" codebase=\"http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0\"width=\"{0}\" height=\"{1}\" name=\"{2}\">" + Environment.NewLine, chartWidth, chartHeight, chartId);
                builder.Append("<param name=\"allowScriptAccess\" value=\"always\" />" + Environment.NewLine);
                builder.AppendFormat("<param name=\"movie\" value=\"{0}\"/>" + Environment.NewLine, chartSWF);
                builder.AppendFormat("<param name=\"FlashVars\" value=\"{0}\" />" + Environment.NewLine, str);
                builder.Append("<param name=\"quality\" value=\"high\" />" + Environment.NewLine);
                builder.Append("<param name=\"wmode\" value=\"transparent\" />" + Environment.NewLine);
     
                builder.AppendFormat("<embed src=\"{0}\" FlashVars=\"{1}\" quality=\"high\" width=\"{2}\" height=\"{3}\" name=\"{4}\"  allowScriptAccess=\"always\" type=\"application/x-shockwave-flash\" pluginspage=\"http://www.macromedia.com/go/getflashplayer\"/>" + Environment.NewLine, new object[] { chartSWF, str, chartWidth, chartHeight, chartId });
                builder.Append("</object>" + Environment.NewLine);
                builder.AppendFormat("<!-- END Code Block for Chart {0} -->" + Environment.NewLine, chartId);
                return builder.ToString();
            }
        }
     
    The chart image is attached.
     
    Anyway, thanks.

     

     

    post-69836-0-37028500-1468421492_thumb.png


  2. Hey! Thanks for the answer.

     

    jsfiddle dont works for me, i must be something wrong.

     

    Anyway, my chart data is where:

     

    <chart showBorder='0' formatNumberScale='0' decimals='1' showLegend='1' decimalSeparator=',' thousandSeparator='.' caption='QUANTIDADE DE O.S. / PREDIO (JUL-15)'
    vDivLineColor='FFFFFF' numDivlines='5' showLabels='1' bgColor='FFFFFF' showValues='1' showYAxisValues='1' yAxisName='Quantidade de O.S.' showPlotBorder='0' 
    canvasbgAlpha='0' canvasBorderAlpha='0' useRoundEdges='0' plotGradientColor='' placeValuesInside='0' yAxisMaxValue='1000' legendNumColumns='3'
    showAlternateHGridColor='0' divLineIsDashed='1' divLineDashLen='1' divLineDashGap='2' plotfillalpha="95" >
    <categories>
    <category label='ICI-I'/>
    <category label='ICI-II' />
    </categories>
    <dataset seriesname='ABERTAS' color='953735' showValues='0'>
    <set value='593' displayValue='593{br}57,06%' showValue='1'/>
    <set value='300' displayValue='300{br}29,41%' showValue='1'/>
    </dataset>
    <dataset seriesname='ACUMULADAS' color='00B0F0' showValues='0'>
    <set value='4' displayValue='4{br}0,10%' showValue='1'/>
    <set value='1' displayValue='1{br}0,10%' showValue='1'/>
    </dataset>
    <dataset seriesname='NO PRAZO' color='4F6228' showValues='0'> 
    <set value='433' displayValue='433{br}41,37%' showValue='1'/>
    <set value='184' displayValue='184{br}18,04%' showValue='1'/>
    </dataset>
    <dataset seriesname='FORA DO PRAZO' color='7030A0' showValues='0'>
    <set value='3' displayValue='3{br}0,10%' showValue='1'/>
    <set value='0' displayValue='0{br}0,00%' showValue='0'/>
    </dataset>
    <dataset seriesname='ATRASADAS' color='376092' showValues='0'>
    <set value='433' displayValue='433{br}41,37%' showValue='1'/>
    <set value='184' displayValue='184{br}18,04%' showValue='1'/>
    </dataset>
    <dataset seriesname='REMANEJADAS (PROX. MES)' color='FF0000' showValues='0'>
    <set value='10' displayValue='10{br}0,98%' showValue='1'/>
    <set value='0' displayValue='0{br}0,00%' showValue='0'/>
    </dataset>
    <styles>
    <definition>
    <style name='myCaption' type='font' font='Verdana' size='14' color='000000' bold='1'/>
    <style name='myDataLabels' type='font' size='10' color='000000' bold='0'/>
    <style name='myDataValues' type='font' color='000000' bold='1'/>
    </definition>
    <application>
    <apply toObject='Caption' styles='myCaption' />
    <apply toObject='DataLabels' styles='myDataLabels' />
    <apply toObject='DataValues' styles='myDataValues' />
    </application>
    </styles>
    </chart>
     
    and this is my js file:
     
    <?xml version="1.0" encoding="iso-8859-1"?><!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
        <head>
            <title>Multi Series Column 2D Chart</title>
            <link href="../../Contents/assets/ui/css/style.css" rel="stylesheet" type="text/css" />
            <link href="../../Contents/assets/prettify/prettify.css" rel="stylesheet" type="text/css" />
            <script language="JavaScript" src="../../Charts/FusionCharts.js"></script>
            <script type="text/javascript" src="../../Contents/assets/ui/js/jquery-1.4.2.min.js"></script>
            <script type="text/javascript" src="../../Contents/assets/prettify/prettify.js"></script>
            <script type="text/javascript" src="../../Contents/assets/ui/js/json2.js"></script>
     
            <script type="text/javascript">
                $(document).ready ( function () {
                    $("a.view-chart-data").click( function () {
                        var chartDATA = '';
                        if ($(this).children("span").html() == "View XML" ) {
                            chartDATA = FusionCharts('ChartId').getChartData('xml').replace(/\</gi, "<").replace(/\>/gi, ">");
                        } else if ($(this).children("span").html() == "View JSON") {
                            chartDATA = JSON.stringify( FusionCharts('ChartId').getChartData('json') ,null, 2);
                        }
                        $('pre.prettyprint').html( chartDATA );
                        $('.show-code-block').css('height', ($(document).height() - 56) ).show();
                        prettyPrint();
                    })
     
                    $('.show-code-close-btn a').click(function() {
                        $('.show-code-block').hide();
                    });
                })
            </script>
        </head>
     
     
        <body>
            <h3 class="chart-title">Multi Series Column 2D Chart</h3>
            <p> </p>
     
     
            <div id="chartdiv" align="center"> FusionCharts. </div>
            <script type="text/javascript">
                var chart = new FusionCharts("../../Charts/MSColumn2D.swf", "ChartId", "760", "300", "0", "0");
                chart.setXMLUrl("../Data/XML/Chart01COR.xml");
                chart.render("chartdiv");
            </script>
     <p> </p>
    <P align="center">Multi-Series Column 2D chart comparing global export index. Click on an item in legend to show/hide the data series.</P>
    <p> </p>
            <div class="qua-button-holder">
                <a class="qua qua-button view-chart-data" href="javascript:void(0)"><span>View XML</span></a>
                <a class="qua qua-button view-chart-data" href="javascript:void(0)"><span>View JSON</span></a>
            </div>
            <div class="show-code-block">
                 <div class="show-code-close-btn"><a class="qua qua-button" href="javascript:void(0)"><span>Close</span></a></div>
                 <pre class="prettyprint"></pre>
             </div>
         </body>
     </html>
     
    Thanks for help-me! :D

  3. Hey there!

     

    I am using some graphics, and all of them I'm having problems with the title. They are being cut and the characters "..." are appearing in place. Is there any way to adjust the title to my chart?

     

    My chart caption XML and styles:

     

    <chart showBorder='0' formatNumberScale='0' decimals='1' showLegend='1' decimalSeparator=',' thousandSeparator='.' caption='QTD. DE O.S./MÊS (JUN - 29)'
     vDivLineColor='FFFFFF' numDivlines='5' showLabels='1' bgColor='FFFFFF' showValues='1' showYAxisValues='1' yAxisName='Quantidade de O.S.' labelDisplay='ROTATE'
     slantlabels='1' showPlotBorder='0' canvasbgAlpha='0' canvasBorderAlpha='0' useRoundEdges='0' plotGradientColor='' placeValuesInside='0' yAxisMaxValue='1600'
     showAlternateHGridColor='0' divLineIsDashed='1' divLineDashLen='1' divLineDashGap='2' subcaption='Meta (95%25) = 0{br}Quantidade de OSs Executadas = 803 (∞%25)'>

     

    <definition> 
    <style name='myCaption' type='font' font='Verdana' size='14' color='000000' bold='1'/> 
    <style name='mySubCaption' type='font' font='Verdana' size='12' color='4F81BD' bold='0'/> 
    <style name='myDataLabels' type='font' size='10' color='000000' bold='0'/> 
    <style name='myDataValues' type='font' color='000000' bold='1'/> 
    </definition>
     
    But my caption was showing "QTD. DE O.S./MÊS (JUN..." with the "...". 
     
    I changed size property, but not works. Anyone knows how solve this? Thanks.