ajitEarthwave

Members
  • Content count

    13
  • Joined

  • Last visited

  • Days Won

    1

Posts posted by ajitEarthwave


  1. Greetings. smile.gif

     

    Could you please, send us relevant sample code and XML file of your issue.

     

    It would be more helpful for us to look into the issue.

     

    After spending some more time on the issue, we figured out that it was our problem.

     

    It was the sequence of events that were causing a issue. We were setting the div height after rendering the chart.

    If we set the div height before rendering the chart it works fine.

     

    Cheers,

    Ajit


  2. Hi,

    We are tying to migrate to FusionCharts XT (v3.2.2) Service Release 2 (Released on 25th January, 2012) and use JavaScript Charts instead of Flash Charts.

     

    We have multiple charts in a page displayed using JQuery Ajax. The first time it works fine but when we make a second call to refresh the container containing the chart, it gives a Javascript error message in Firebug

     

    #06091847 chartobject-2 Warning >> A FusionChart oject with the specified id "divChart3457Id" already exists. Renaming it to chartobject-2

    [break On This Error]

     

    ...id+'" already exists. Renaming it to '+(this.id=a.uniqueId())));if(e.type&&e.typ...

     

    FusionCharts.js (line 19)

     

    The above situation doesn't arise if we use Flash Charts.

     

    Can you please provide inputs for the above?

     

    Regards,

    Ajit


  3. Hi,

    We have been using FusionCharts since the last couple of year and are quite happy with it. We are in the process of migrating from Flash to Javascript Charts. Our integration with Fusion Charts works fine in case of Flash charts.

     

    We are trying to replace them with JavaScript Charts & are facing some issues. The new version we are using is FusionCharts XT (v3.2.2) Service Release 2 (Released on 25th January, 2012)

     

    We have multiple charts in a page displayed using Jquery (Ajax call). The parent div containing the chart has a fixed width and height (specified in XXpx)and chart's width & height are 100%.

     

    If we display 1 JavaScript chart in the page, the height of chart is around 40px short of the parent container.

    If we display 2 JavaScript charts in the page, the height of the second chart becomes around lot bigger than the parent and spills outside the container. The more charts we add on the page, the height of new charts increases.

    The charts works fine if we remove FusionCharts.setCurrentRenderer('javascript');

    Moreover, if the height and width of chart are not specified in % it works fine even with JavaScript charts.

     

    Can you please shed some light on resolving the height issue?

     

     

    Regards,

    Ajit


  4. Hi,

    We are using Fusion Charts are quite happy with it.

     

    We are facing some minor UI issues.

     

    We want X-Axis labels should always be slant. So we have used slantLabels ='1'. We have 2 different views for the same chart.

     

    When we view it in a smaller area it works fine but if we view in a bigger area the Slant Labels appear not to work anymore.

     

    The XML is same for both the views.

     

    The XML is attached below:

    <chart canvasBgColor='EFEFEF' divLineColor='BDB3BD' showAlternateHGridColor='0' slantLabels ='1' showValues='0' exportEnabled='1' exportShowMenuItem='1' exportAtClient='0' exportHandler='http://1.111.11.111/Earthport/ChartExport.Sample' exportFormats='PDF=Export as PDF|PNG=Export as PNG Image|JPG=Export as JPEG Image' exportAction='download' exportCallback='save' showExportDialog='1' exportFileName='EarthportWidget' aboutMenuItemLabel='About Earthwave' aboutMenuItemLink='n-http://www.earthwave.com.au' showShadow='0' bgAlpha='0,0' legendBgAlpha='0' canvasBorderAlpha='0' legendBorderAlpha='0' legendShadow='0' legendBorderThickness='0' showBorder='0' outCnvBaseFontColor='666666' outCnvBaseFont='Arial, Helvetica' baseFontColor='666666' baseFontSize='10' baseFont='Arial' ><categories><category label='Oct-10' /> <category label='Nov-10' /> <category label='Dec-10' /> <category label='Jan-11' /> <category label='Feb-11' /> <category label='Mar-11' /> <category label='Apr-11' /> <category label='May-11' /> <category label='Jun-11' /> <category label='Jul-11' /> <category label='Aug-11' /> <category label='Sep-11' /> </categories><dataset seriesName='Incidents'><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='77597226' /><set value='14589363' /><set value='127740269' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /></dataset><dataset seriesName='Exposures'><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /></dataset><dataset seriesName='Vulnerabilities'><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /><set value='0' /></dataset></chart>

     

    Screenshots attached as well:

     

    Regards,

    Ajit

    post-8139-0-66020200-1314931135_thumb.jpg

    post-8139-0-12630400-1314931191_thumb.jpg


  5. Hi,

    We are using Fusion Charts V3.1.1 and Fusion Widgets in our intranet application.

     

    We are trying to integrate the Intranet site with a Third Party product which is having issues in displaying the Tooltip on the widgets. It currently displays undefined, without the integration it works fine.

     

    There support is asking for version of Flash was used to create the charts. If you can let us know so that we can talk to them and resolve the tooltip rewrite issue.

     

    Regards,

    Ajit


  6. Hi,

    We are using stacked area 2D chart.

     

    It works very well with multiple values but doesn't display anything when single value is present.

     

    PFA the XML used to generate the chart.

     

    <chart canvasBgColor='EFEFEF' divLineColor='BDB3BD' showAlternateHGridColor='0' labelDisplay='Rotate' slantLabels='1' yAxisName='' numDivLines='5' showValues='0' exportEnabled='1' exportShowMenuItem='1' exportAtClient='0' exportHandler='http://xxxxxx/ChartExport_1111.Sample' exportFormats='PDF=Export as PDF|PNG=Export as PNG Image|JPG=Export as JPEG Image' exportAction='download' exportCallback='save' showExportDialog='1' exportFileName='xxxx' aboutMenuItemLabel='About xxx' aboutMenuItemLink='n-http://xxxx' showShadow='0' bgAlpha='0,0' legendBgAlpha='0' canvasBorderAlpha='0' legendBorderAlpha='0' legendShadow='0' legendBorderThickness='0' showBorder='0' outCnvBaseFontColor='666666' outCnvBaseFont='Arial, Helvetica' baseFontColor='666666' baseFontSize='10' baseFont='Arial' ><categories><category label='25-May-11' /> </categories><dataset seriesName='High' renderAs='line'><set value='0' /></dataset><dataset seriesName='Medium' renderAs='line'><set value='3' /></dataset><dataset seriesName='Low' renderAs='line'><set value='10' /></dataset><dataset seriesName='Info' renderAs='line'><set value='60' /></dataset></chart>

     

    Can you please guide me to plot the single value?

     

    The XML when used with Stacked Column 3D / Stacked Bar 3D chart works well.

     

    Regards,

    Ajit


  7. Hi,

    We are currently evaluating Fusion Charts. We are facing a small issue regarding alignment of Y axis label.

    Is there a property that we can use to move it upwards as we would like to align in center with respect to the Y Axis only and not whole chart.

     

    Please refer to the image attached.

     

     

    post-8139-003637800 1287122796_thumb.png

     

    Regards,

    Ajit