nheilsb

Members
  • Content count

    9
  • Joined

  • Last visited

Posts posted by nheilsb


  1. Hello FC Team,

     

     

     

    I am using a FusionChart Enterprise in our current J2EE project and everything works fine both on our local machine and staging server running under tomcat. However, when it is deployed in production environment, the chart is not loading and on right click, I am getting "Movie not loaded" as disabled..

     

     

     

    Here's my configuration:

     

    1. Please see image attached on the structure of the project deployed in tomcat

     

    2. In my jsp page, I setup like this:

     

    var strXml = "... data in here comes from server ...";

     

    var myChart = new FusionCharts("charts/AngularGauge.swf", "myChartId", "570", "140", "0", "1");

     

    myChart.setDataXML(strXml);

     

    myChart.render("chartdiv");

     

     

     

    Could you please let me know if I am missing anything here?

     

    Again, this configuration is working on my local setup and in our staging server running on tomcat.

     

     

     

    Your quick response is highly appreciated.

     

     

     

    Many thanks.

     

     

     

    Neil

    post-9145-12844158858_thumb.png


  2. Here are the details:

     

     

     

    1.) I have 12 fusion chart images for my project. And these images are distributed in different tabs like:

     

     

     

    1st tab - Region (contains 3 chart images for region)

     

    2nd tab - City (contains 3 chart images for city)

     

    3rd tab - State (contains 3 chart images for state)

     

    4th tab - National (contains 3 chart images for national)

     

     

     

    I set the FC Export Parameters like the one below:

     

    exportFileName='hbi_details__chartId_timestamp'

     

    showExportDialog='0'

     

    exportEnabled='1'

     

    exportAtClient='0'

     

    exportAction='save'

     

    exportTargetWindow='_self'

     

    exportHandler='charts/FCExporter.jsp'

     

     

     

    2.) I setup the jsp like the one attached - results.txt. There are two main div I used for the graphs:

     

    a.) hbi_panel - this is for the active tab

     

    b.) export_all - for generating and exporting all the chart images. I used the style - visibitity: hidden.

     

     

     

    3. When I run using Firefox, everything works fine. All images is exported back to server. However, when I test it using IE, only the charts within the current tab, that is under region tab are the ones exported back to server. The rest were not. So I setup this call that is intended only for IE.

     

     

     

    function sendExportChart(){

     

    var myExportComponent = new FusionChartsExportObject({

     

    id: "fcExporter1",

     

    swfLocation: loc + "charts/FCExporter.swf",

     

    exportAttributes: { defaultExportFormat: 'jpg' },

     

    debugMode: true

     

    });

     

    myExportComponent.checkFlashVersion = true;

     

    myExportComponent.componentAttributes.fullMode = '1';

     

    myExportComponent.componentAttributes.showAllowedTypes = '1';

     

    myExportComponent.Render("export_all");

     

    exportComponent.BeginExport();

     

    }

     

     

     

    3. When I run again, nothing happens. Still, only the images under that region were saved back to server. I did not even see any error in IE.

     

     

     

    I hope this clarifies everything on your side.

     

     

     

    Again, your quick response is highly appreciated.

    results.txt


  3. Hello Experts,

     

     

     

    Can you have someone take a look at this please? I need to fix this asap for we are behind the schedule. Please help!!!

     

     

     

    By the way, in addition to the ones above, I put all the chartIds in the div like the code snippet attached.

     

     

     

    All images are working (rendering/exporting) in Firefox, however in IE (7&8), only the first 3 divs were saved back to the server.

     

     

     

    Can you please advise if I missed out something here?

     

     

     

    Your quick response is highly appreciated.

    post-9145-128441586914_thumb.png


  4. Hello FC Team,

     

     

     

    I have setup a project that uses FC. The rendering of the FC works fine in Firefox and IE. For the exporting part, I did not set any javascript code that will do the exporting. I just use this setting:

     

     

     

    exportFileName='testing';

     

    showExportDialog='0'

     

    exportEnabled='1'

     

    exportAtClient='0'

     

    exportAction='save'

     

    exportHandler='FCExporter.jsp'

     

     

     

    I have 12 images that needs to be saved back to the server. The above code is working in Firefox. But in IE, it's not. So I found some tips from the forum to use a FusionChartsExportObject. Below is the code snippet that is intended only for IE:

     

     

     

    var myExportComponent = new FusionChartsExportObject({

     

    id: "fcExporter1",

     

    swfLocation: loc + "charts/FCExporter.swf",

     

    exportAttributes: { defaultExportFormat: 'jpg' },

     

    debugMode: true

     

    });

     

    myExportComponent.checkFlashVersion = true;

     

    myExportComponent.componentAttributes.fullMode = '1';

     

    myExportComponent.componentAttributes.showAllowedTypes = '1';

     

    myExportComponent.Render("export_all");

     

    myExportComponent.BeginExport();

     

     

     

    With this, I was able to saved the first 3 files and the others were not.

     

     

     

    I'm not sure here what's lacking. I did not even see any javascript error in IE and in my application logs.

     

     

     

    Could you please have someone take a look at this issue? Your quick response is greatly appreciated.

     

     

     

    Many thanks.

     

     

     

    Neil