Search the Community

Showing results for tags 'upgrade'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Company Forums
    • Company News
  • Product Forums
    • FusionCharts XT
    • FusionWidgets XT
    • PowerCharts XT
    • FusionMaps XT
    • Collabion Charts for SharePoint
    • jQuery Plugin for FusionCharts
    • AngularJS plugin
    • ReactJS plugin
  • General Forums
    • FusionCharts Jobs and Consultation
    • FusionLounge

Found 10 results

  1. Between version change 3.9 -> 3.12.1 when enabling/disabling a series from the legend panel. The series used to simply hide, without adapting and recentering of the visible series, is there a config to keep that behavior in the new version?
  2. Hello, I have a question you people might be able to help me with, thanks in advance! I just replaced the old FusionCharts v3.9 with v3.12 but out of all maps my maps are not rendering: fusioncharts.js?v=3.12:1024 Uncaught TypeError: O.register(...) is not a constructor at c._createGradientLegend (fusioncharts.js?v=3.12:1024) at c.init (fusioncharts.js?v=3.12:951) at c.init (fusioncharts.maps.js:97) at Object.v.createChart (fusioncharts.js?v=3.12:879) at u.core.render (fusioncharts.js?v=3.12:1860) at a.executeWaitingCommands (fusioncharts.js?v=3.12:126) at fusioncharts.js?v=3.12:1867 at p (fusioncharts.js?v=3.12:125) at success (fusioncharts.js?v=3.12:126) at Object.A [as job] (fusioncharts.js?v=3.12:54) Does anyone have an idea what could this be related to? Thanks!
  3. Hi, While upgrading from version v1.1.8.0 to v2.4.0.2 many / all our charts will be broken. The error we occured is: WebPart can't be loaded. Please contact your site administrator or write to Collabion Support. Column 'CategoriesSortColumn' does not exist. It may have been deleted by another user. at Microsoft.SharePoint.SPFieldCollection.GetField(String strName, Boolean bThrowException) at Microsoft.SharePoint.SPListItem.GetValue(String strName, Boolean bThrowIfValueMissing, Boolean bThrowIfFieldMissing) at Collabion.Charts.DAL.Managers.ChartConfigurationManager.b__10_0(SPListItem item) at Collabion.Charts.DAL.Managers.ChartConfigurationManager.<>c__DisplayClass10_1.b__2(SPListItem i) at Collabion.Charts.DAL.ListHelper.Get[T](SPWeb web, String listTitle, SPQuery query, Func`2 converter) at Collabion.Charts.DAL.Managers.DataManager.Get[T](SPQuery query, Func`2 converter) at Collabion.Charts.CollabionChartWebPart.PreRenderWebPart() at Collabion.Common.SharePoint.Base.WebParts.WebPartBase.OnPreRender(EventArgs e) Method: Microsoft.SharePoint.SPField GetField(System.String, Boolean) File: Line: 0 Hide... For example export for old (upgraded v1.1.8.0 -> v2.4.0.2) chart and for same new (created with v2.4.0.2) chart available in attach We have many charts and re creation all of them by WebPart Editor is unacceptable Is available any solutions for this issue? New_chart.xml Old_chart.xml
  4. Hi, Is there a new WAR file with the new libraries? My exports don't work properly, for export to pdf, png, svg and jpeg. As well, I used to have a 3d pie chart that when right clicked on, would be able to show the 2d version. I've lost that functionality, is there some way to show the 2d version? Thanks, Shashank
  5. Hi, I have a US and a global map that I am trying to render. It worked fine on 3.2.2 on all browsers, but due to an issue in chrome, I had to upgrade, and now i get the message 'chart type not supported'. What happened in chrome recently that would cause my normal bar charts to not update when filters are changed? That's why I had to update, but if there is another fix around it, then I would rather just go back to old code. Or if I could just keep maps libraries at 3.2.2 that would be great. Thanks for the help, Shashank
  6. Hi, I have two funnel charts that work properly on load, and while browsing through my filters which still yield data. Once I change filters to a scenario with no data, I see the message 'No data to display', which is still correct. Then, when I set filters back to a scenario that does return data, the chart is not reloaded. Instead the message stays. This is only an issue with the funnel, and does not happen with pie, bar or line graphs. I have just updated from version 3.2.2 to 3.5, and saw this issue immediately. Also, when developer tools are open, the functionality works (I am using the latest version of chrome on windows 7). Thanks for your time! Shashank
  7. I recently upgraded from FusionCharts 3.2.1 to XT. I followed the instructions here, including the instructions relate to FusionWidgets: http://docs.fusioncharts.com/charts/contents/Introduction/Upgrading32.html and am using the following line to render JS charts by default: FusionCharts.setCurrentRenderer('javascript'); Previously, our system was set up to render Flash charts from XML data, and I haven't changed any of the existing code. I'm now seeing the following error in the console, on a page that renders a number of angular gauges: Uncaught ReferenceError: parseTooltext is not defined FusionCharts.HC.Widgets.js:193 p.series FusionCharts.HC.Widgets.js:193 p.chart FusionCharts.HC.Widgets.js:120 R.init FusionCharts.HC.js:521 p.init FusionCharts.HC.Widgets.js:105 g.createChart FusionCharts.HC.js:460 j.extend.render FusionCharts.HC.js:782 a.renderer.render FusionCharts.js:56 a.extend.render FusionCharts.js:64 dash.renderXML dashboard.js:40 (anonymous function) dashboard.js:227 c jquery-1.10.2.js:3048 p.fireWith jquery-1.10.2.js:3160 k jquery-1.10.2.js:8235 r jquery-1.10.2.js:8778 dash.renderXML (dashboard.js, line 40) calls chart.setDataXml() with the following xml: <?xml version="1.0" encoding="utf-8"?> <chart showLimits="0" showAboutMenuItem="0" chartRightMargin="8" lowerLimit="-100" clickURL="JavaScript:dash.change_metric(0);" gaugeEndAngle="0" tickValueStep="1" bgColor="ffffff" tickValueDistance="14" autoScale="0" palette="1" gaugeStartAngle="180" showTickValues="1" chartTopMargin="5" exportEnabled="1" chartLeftMargin="8" chartBottomMargin="5" showBorder="0" imageSaveURL="/data/image" exportFormats="PNG=Save as Image" decimals="1" showTickMarks="1" upperLimit="100"> <colorRange> <color code="FFFFFF" maxValue="-15.6" minValue="-100.0"/> <color code="FF0000" maxValue="1.7" minValue="-15.6"/> <color code="f2f20c" maxValue="14.5" minValue="1.7"/> <color code="0cf20c" maxValue="62.2" minValue="14.5"/> <color code="FFFFFF" maxValue="100.0" minValue="62.2"/> </colorRange> <dials> <dial rearExtension="5" toolText="Amazon.com: 62.2" id="brand1" value="62.2"/> </dials> <trendpoints> <point color="666666" alpha="100" thickness="2" startValue="7.21319806914" displayValue=" "/> </trendpoints> <styles> <definition> <style bgColor="ffffff" type="font" name="defaultfont"/> </definition> <application> <apply toObject="value" styles="defaultfont"/> <apply toObject="limitvalues" styles="defaultfont"/> </application> </styles> </chart> dashboard.js, line 227 is the line that calls this function. The gauges are not being rendered; they just show up as blank boxes. Any idea where this error might be coming from or how to fix it? Thanks!
  8. I recently upgraded from FusionCharts 3.2.1 to XT. I have followed the instructions here: http://docs.fusioncharts.com/charts/contents/Introduction/Upgrading32.html and am using the following line to render JS charts by default: FusionCharts.setCurrentRenderer('javascript'); Previously, our system was set up to render Flash charts from XML data, and I haven't changed any of the existing code. Now, our zoomline chart is not rendering correctly. Screenshot of chart before upgrade: Screenshot of broken chart after upgrade: In the console, I see the following error: Uncaught TypeError: Cannot read property 'data' of undefined FusionCharts.js:26 This is the XML being passed to the chart: <?xml version="1.0" encoding="utf-8"?> <chart showLegend="1" showAboutMenuItem="0" anchorAlpha="0" formatNumber="1" drawAnchors="0" showShadow="1" showDivLineSecondaryValue="0" showSecondaryLimits="0" setAdaptiveYMin="1" lineThickness="2" exportEnabled="1" showYAxisValues="1" canvasBorderColor="99978A" baseFontColor="666666" showToolTip="1" plotSpacePercent="70" showPlotBorder="0" labelStep="10" showValues="0" setAdaptiveSYMin="0" adjustDiv="0" connectNullData="1" xAxisName="Latest data is from 01/31/2013" seriesNameInToolTip="1" labelDisplay="WRAP" chartTopMargin="40" pixelsPerPoint="1" decimals="1" imageSaveURL="/data/image" formatNumberScale="0" exportFormats="PNG=Save as Image" drawToolbarButtons="0" yAxisName="Score"> <categories> <category label="01/01/2013"/> <category label="01/02/2013"/> <category label="01/03/2013"/> <category label="01/04/2013"/> <category label="01/05/2013"/> <category label="01/06/2013"/> <category label="01/07/2013"/> <category label="01/08/2013"/> <category label="01/09/2013"/> <category label="01/10/2013"/> <category label="01/11/2013"/> <category label="01/12/2013"/> <category label="01/13/2013"/> <category label="01/14/2013"/> <category label="01/15/2013"/> <category label="01/16/2013"/> <category label="01/17/2013"/> <category label="01/18/2013"/> <category label="01/19/2013"/> <category label="01/20/2013"/> <category label="01/21/2013"/> <category label="01/22/2013"/> <category label="01/23/2013"/> <category label="01/24/2013"/> <category label="01/25/2013"/> <category label="01/26/2013"/> <category label="01/27/2013"/> <category label="01/28/2013"/> <category label="01/29/2013"/> <category label="01/30/2013"/> <category label="01/31/2013"/> </categories> <dataset color="cd905c" seriesname="Toys &quot;R&quot; Us, Buzz"> <set value="15.0" toolText="Toys "R" Us, Buzz, 2013-01-01, 15.0"/> <set value="11.7" toolText="Toys "R" Us, Buzz, 2013-01-02, 11.7"/> <set value="16.9" toolText="Toys "R" Us, Buzz, 2013-01-03, 16.9"/> <set value="14.1" toolText="Toys "R" Us, Buzz, 2013-01-04, 14.1"/> <set value="13.9" toolText="Toys "R" Us, Buzz, 2013-01-05, 13.9"/> <set value="7.4" toolText="Toys "R" Us, Buzz, 2013-01-06, 7.4"/> <set value="6.0" toolText="Toys "R" Us, Buzz, 2013-01-07, 6.0"/> <set value="6.2" toolText="Toys "R" Us, Buzz, 2013-01-08, 6.2"/> <set value="9.6" toolText="Toys "R" Us, Buzz, 2013-01-09, 9.6"/> <set value="13.3" toolText="Toys "R" Us, Buzz, 2013-01-10, 13.3"/> <set value="14.2" toolText="Toys "R" Us, Buzz, 2013-01-11, 14.2"/> <set value="13.0" toolText="Toys "R" Us, Buzz, 2013-01-12, 13.0"/> <set value="10.2" toolText="Toys "R" Us, Buzz, 2013-01-13, 10.2"/> <set value="9.0" toolText="Toys "R" Us, Buzz, 2013-01-14, 9.0"/> <set value="9.0" toolText="Toys "R" Us, Buzz, 2013-01-15, 9.0"/> <set value="8.8" toolText="Toys "R" Us, Buzz, 2013-01-16, 8.8"/> <set value="7.9" toolText="Toys "R" Us, Buzz, 2013-01-17, 7.9"/> <set value="5.9" toolText="Toys "R" Us, Buzz, 2013-01-18, 5.9"/> <set value="6.5" toolText="Toys "R" Us, Buzz, 2013-01-19, 6.5"/> <set value="7.2" toolText="Toys "R" Us, Buzz, 2013-01-20, 7.2"/> <set value="9.6" toolText="Toys "R" Us, Buzz, 2013-01-21, 9.6"/> <set value="10.6" toolText="Toys "R" Us, Buzz, 2013-01-22, 10.6"/> <set value="10.9" toolText="Toys "R" Us, Buzz, 2013-01-23, 10.9"/> <set value="9.8" toolText="Toys "R" Us, Buzz, 2013-01-24, 9.8"/> <set value="6.1" toolText="Toys "R" Us, Buzz, 2013-01-25, 6.1"/> <set value="4.3" toolText="Toys "R" Us, Buzz, 2013-01-26, 4.3"/> <set value="6.1" toolText="Toys "R" Us, Buzz, 2013-01-27, 6.1"/> <set value="9.4" toolText="Toys "R" Us, Buzz, 2013-01-28, 9.4"/> <set value="10.2" toolText="Toys "R" Us, Buzz, 2013-01-29, 10.2"/> <set value="7.8" toolText="Toys "R" Us, Buzz, 2013-01-30, 7.8"/> <set value="5.2" toolText="Toys "R" Us, Buzz, 2013-01-31, 5.2"/> </dataset> <dataset color="1875bb" seriesname="Ford, Buzz"> <set value="30.6" toolText="Ford, Buzz, 2013-01-01, 30.6"/> <set value="30.5" toolText="Ford, Buzz, 2013-01-02, 30.5"/> <set value="29.0" toolText="Ford, Buzz, 2013-01-03, 29.0"/> <set value="35.1" toolText="Ford, Buzz, 2013-01-04, 35.1"/> <set value="35.6" toolText="Ford, Buzz, 2013-01-05, 35.6"/> <set value="37.6" toolText="Ford, Buzz, 2013-01-06, 37.6"/> <set value="31.6" toolText="Ford, Buzz, 2013-01-07, 31.6"/> <set value="31.2" toolText="Ford, Buzz, 2013-01-08, 31.2"/> <set value="30.4" toolText="Ford, Buzz, 2013-01-09, 30.4"/> <set value="31.0" toolText="Ford, Buzz, 2013-01-10, 31.0"/> <set value="28.8" toolText="Ford, Buzz, 2013-01-11, 28.8"/> <set value="35.7" toolText="Ford, Buzz, 2013-01-12, 35.7"/> <set value="36.1" toolText="Ford, Buzz, 2013-01-13, 36.1"/> <set value="38.1" toolText="Ford, Buzz, 2013-01-14, 38.1"/> <set value="31.3" toolText="Ford, Buzz, 2013-01-15, 31.3"/> <set value="31.6" toolText="Ford, Buzz, 2013-01-16, 31.6"/> <set value="32.0" toolText="Ford, Buzz, 2013-01-17, 32.0"/> <set value="33.9" toolText="Ford, Buzz, 2013-01-18, 33.9"/> <set value="36.0" toolText="Ford, Buzz, 2013-01-19, 36.0"/> <set value="39.1" toolText="Ford, Buzz, 2013-01-20, 39.1"/> <set value="37.1" toolText="Ford, Buzz, 2013-01-21, 37.1"/> <set value="34.9" toolText="Ford, Buzz, 2013-01-22, 34.9"/> <set value="30.9" toolText="Ford, Buzz, 2013-01-23, 30.9"/> <set value="33.4" toolText="Ford, Buzz, 2013-01-24, 33.4"/> <set value="36.8" toolText="Ford, Buzz, 2013-01-25, 36.8"/> <set value="39.3" toolText="Ford, Buzz, 2013-01-26, 39.3"/> <set value="36.9" toolText="Ford, Buzz, 2013-01-27, 36.9"/> <set value="33.8" toolText="Ford, Buzz, 2013-01-28, 33.8"/> <set value="31.6" toolText="Ford, Buzz, 2013-01-29, 31.6"/> <set value="28.1" toolText="Ford, Buzz, 2013-01-30, 28.1"/> <set value="27.2" toolText="Ford, Buzz, 2013-01-31, 27.2"/> </dataset> <styles> <definition> <style type="font" name="CaptionFont" size="12"/> </definition> <application> <apply toObject="caption" styles="CaptionFont"/> </application> </styles> </chart> Any ideas on where to start debugging this one? Any advice would be helpful. Thanks!
  9. I recently upgraded from FusionCharts 3.2.1 to XT. I followed the instructions here: http://docs.fusioncharts.com/charts/contents/Introduction/Upgrading32.html and am using the following line to render JS charts by default: FusionCharts.setCurrentRenderer('javascript'); Previously, our system was set up to render Flash charts from XML data, and I haven't changed any of the existing code. In our radar chart, I'm now seeing random yellow and green borders in the chart, which previously defaulted to blue and red. No color settings have been changed in the code. Correct borders (before upgrade): Wrong borders (after upgrade): When I inspect the element in Chrome's dev tools, this is the blue area w/yellow border: <path fill="#1875bb" stroke="#f6bd0f" d="M405,188.00464285714287L257.2115117711864,153.14261345436068L232.51679834241202,310.3681652202647L331.6978216117407,423.2135418385827L479.1992330188848,425.07629497297097L597.9277881645809,315.03450867709086L560.1779126402544,147.24974412707877Z" stroke-opacity="1" fill-opacity="0.3" stroke-width="2" style=""></path> Red w/green border: <path fill="#ff0000" stroke="#8bba00" d="M405,259.48107142857145L383.293565791393,253.68969635110923L383.1156538798386,275.99495919322226L399.6176722162467,282.1765188063295L415.3802035829528,292.55471484077833L419.6855480543188,274.35188051124123L423.2426415157442,256.45197884827263Z" stroke-opacity="1" fill-opacity="0.3" stroke-width="2" style=""></path> This is the XML being passed to the chart: <?xml version='1.0' encoding='utf-8'?> <chart showLegend='1' showAboutMenuItem='0' showToolTip='1' seriesNameInToolTip='1' exportEnabled='1' plotFillAlpha='30' radarFillColor='FFFFFF' imageSaveURL='/data/image' exportFormats='PNG=Save as Image' decimals='1' subcaption='Latest data is from 03/11/2014'> <categories> <category label="Buzz"/> <category label="Impression"/> <category label="Quality"/> <category label="Value"/> <category label="Reputation"/> <category label="Satisfaction"/> <category label="Recommend"/> </categories> <dataset plotBorderThickness='0' anchorAlpha='0' plotFillAlpha='20' color='000000' seriesname='' plotBorderAlpha='0'> <set /> <set /> <set /> <set /> <set /> <set /> <set /> </dataset> <dataset plotBorderThickness='2' anchorAlpha='100' plotFillAlpha='10' color='1875bb' seriesname='Amazon.com' plotBorderAlpha='100'> <set value='28.1'/> <set value='64.0'/> <set value='59.9'/> <set value='57.2'/> <set value='57.9'/> <set value='67.0'/> <set value='67.2'/> </dataset> <dataset plotBorderThickness='2' anchorAlpha='100' plotFillAlpha='10' color='ff0000' seriesname='Sector Median' plotBorderAlpha='100'> <set value='3.9'/> <set value='9.4'/> <set value='7.6'/> <set value='4.2'/> <set value='8.1'/> <set value='5.1'/> <set value='7.9'/> </dataset> <styles> <definition> <style color='000000' size='10' type='font' bold='1' name='boldfont' /> <style color='000000' size='10' type='font' bold='0' name='defaultfont' /> </definition> <application> <apply toObject='CAPTION' styles='boldfont' /> <apply toObject='XAXISNAME' styles='defaultfont' /> <apply toObject='YAXISNAME' styles='defaultfont' /> </application> </styles> </chart> Any idea why these border colors changed randomly? Do I now need to specify the color explicitly? Please let me know how to fix. Thanks!
  10. Hello, Need help with the upgrade process from 3.2.2.1 to 3.3.1 version. Our company bought an enterprise license and we are currently using FusionCharts.dll as a License key, dll version is 3.2.2.1. All charts and widgets for that version are working correct. However when I updated to the latest 3.3.1 FusionWidgets (downloaded from public trial) I got the FusionWidgets Trial message box rendered at the top left of every FusionWidget. How to get new license FusionCharts.dll for 3.3.1 version? Please provide necessary steps to get registered 3.3.1 version. Thank you.