Search the Community

Showing results for tags 'xml'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Company Forums
    • Company News
  • Product Forums
    • FusionCharts XT
    • FusionWidgets XT
    • PowerCharts XT
    • FusionMaps XT
    • Collabion Charts for SharePoint
    • jQuery Plugin for FusionCharts
    • AngularJS plugin
    • ReactJS plugin
  • General Forums
    • FusionCharts Jobs and Consultation
    • FusionLounge

Found 12 results

  1. Xml schema for version 3.8

    Hi, Can you please provide the xml schema for the version 3.8 of fusioncharts XT?I want the schema to generate the java objects from them, so that I can use it for generating the required xml.We need to update to latest version of fusioncharts and need to have the xml schema for that.Please provide the same. I have posted the same query few days back and have been waiting,But could not get a reply yet.We are facing few issues that seems to be fixable only with the latest version. So please help!! Thanks, Deepti.
  2. Adding the <axis> as strXML prevents the chart from Rendering. $strXML .="<axis title='item 2014' tickwidth='10' divlinedashed='1'>"; $strXML .="<dataset seriesName='item 2014' >"; if ($result2) { while($ors1 = mysql_fetch_array($result2)) { $strXML .= "<set value='".$ors1['item']."' />"; } } $strXML .= "</dataset>"; $strXML .="</axis>"; $strXML .="<axis title='item 2015' tickwidth='10' divlinedashed='1'>"; $result3 = mysql_query($strQuery15) or die(mysql_error()); $strXML .="<dataset seriesName='item 2015'>"; if ($result3) { while($ors1 = mysql_fetch_array($result3)) { $strXML .= "<set value='".$ors1['item']."' />"; } } $strXML .= "</dataset>"; $strXML .="</axis>"; $strXML .="<axis title='item 2016' numdivlines='10' tickwidth='10' divlinedashed='1'>"; $result4 = mysql_query($strQuery16) or die(mysql_error()); $strXML .="<dataset seriesName='item 2016'>"; if ($result4) { while($ors1 = mysql_fetch_array($result4)) { $strXML .= "<set value='".$ors1['item']."' />"; } } mysql_close($link); $strXML .= "</dataset></axis>";
  3. I am trying to pass an xml string into the datasource argument and I keep getting an invalid data message when I load the page. Any help would be appreciated. <head> <title>FusionCharts XT - Column 2D Chart - Data from a database</title> <link rel="stylesheet" type="text/css" href="css/style.css" /> <!-- Include the `fusioncharts.js` file. This file is needed to render the chart. Ensure that the path to this JS file is correct. Otherwise, it may lead to JavaScript errors. --> <script src="fusioncharts/fusioncharts.js"></script> </head> <?php include("fusioncharts/fusioncharts.php"); $servername = "localhost"; $username = "*****"; $password = "****"; $dbname = "***"; // Create connection $dbhandle = new mysqli($servername, $username, $password, $dbname); // Check connection if ($dbhandle->connect_error) { die("Connection failed: " . $dbhandle->connect_error); } $dbhandle = new mysqli($servername, $username, $password, $dbname); // Render an error message, to avoid abrupt failure, if the database connection parameters are incorrect if ($dbhandle->connect_error) { exit("There was an error with your connection: ".$dbhandle->connect_error); } // Form the SQL query that returns the top 10 most populous countries $strQuery = "SELECT * FROM scores"; //$retval = mysql_query( $sql, $conn ); // Execute the query, or else return the error message. $result = $dbhandle->query($strQuery) or exit("Error code ({$dbhandle->errno}): {$dbhandle->error}"); //while($row = mysql_fetch_assoc($result)) { // echo "Category :{$row['category']} <br> ". // "score : {$row['score']} <br> ". // "--------------------------------<br>"; // } $strXML ="'<chart><categories>"; // If the query returns a valid response, prepare the XML string if ($result) { // The `$arrData` array holds the chart attributes and data //$arrData["data"] = array(); // Push the data into the array while($row = mysqli_fetch_array($result)) { $strQuery2 = "select * from desirescores where ID =" . $row['ID']; //echo $strQuery2; $result2 = mysqli_query($dbhandle, $strQuery2) or die(mysqli_error()); $ors2 = mysqli_fetch_array($result2); //Generate <set label='..' value='..'/> //free the resultset $strXML .= "<category label='" . $ors2['category'] . "' />"; mysqli_free_result($result2); } } $strXML .= "</categories><dataset seriesName='Athlete Scores'>"; $strXML .="<set value='35' /><set value='48' /><set value='31' /><set value='40' /><set value='36' /><set value='36' /><set value='36' /><set value='36' /></dataset></chart>'"; echo $strXML; $radarChart = new FusionCharts("radar", "myFirstChart" , 600, 300, "chart-1", "XML", $strXML); $radarChart->render(); $dbhandle->close(); ?> <div id="chart-1"><!-- Fusion Charts will render here--></div>
  4. Hi Fusion Team and Forum members. I have a quite tricky requirement. I want to be able to influence on format of Sum in stacked column chart. I know, I can use prefix/suffix etc for Number formatting, but in this case I want different sums to be show differently. Imagine here http://jsfiddle.net/fusioncharts/15zbv887/, I want only Q2 to be shown as $29.8K, but other columns should show just number without prefix. Thanks.
  5. Problem with XML Dataset

    Testing out XT and the simple test works fine. I need to get the Combination 2 yaxis chart working. Using the sample data I expected the code below to work. The fusioncharts.js is ok as it works in the simple example. However the code below does not work. I have tried locally and also from my server. Can anyone spot any error or reason why it will not work please. <html> <head> <title>My first chart using FusionCharts Suite XT</title> <script type="text/javascript" src="fusioncharts/fusioncharts.js"></script> <script type="text/javascript" src="fusioncharts/themes/fusioncharts.theme.fint.js"></script> <script type="text/javascript"> FusionCharts.ready(function(){ var revenueChart = new FusionCharts({ "type": mscombidy2d", "renderAt": "chartContainer", "width": "500", "height": "300", "dataFormat": "xml", "dataSource": <chart caption="Revenues and Profits" subcaption="For last year" xaxisname="Month" pyaxisname="Amount (In USD)" syaxisname="Profit %" numberprefix="$" snumbersuffix="%" syaxismaxvalue="50" theme="fint"> <categories> <category label="Jan" /> <category label="Feb" /> <category label="Mar" /> <category label="Apr" /> <category label="May" /> <category label="Jun" /> <category label="Jul" /> <category label="Aug" /> <category label="Sep" /> <category label="Oct" /> <category label="Nov" /> <category label="Dec" /> </categories> <dataset seriesname="Revenues"> <set value="16000" /> <set value="20000" /> <set value="18000" /> <set value="19000" /> <set value="15000" /> <set value="21000" /> <set value="16000" /> <set value="20000" /> <set value="17000" /> <set value="22000" /> <set value="19000" /> <set value="23000" /> </dataset> <dataset seriesname="Profits" renderas="area" showvalues="0"> <set value="4000" /> <set value="5000" /> <set value="3000" /> <set value="4000" /> <set value="1000" /> <set value="7000" /> <set value="1000" /> <set value="4000" /> <set value="1000" /> <set value="8000" /> <set value="2000" /> <set value="7000" /> </dataset> <dataset seriesname="Profit %" parentyaxis="S" renderas="line" showvalues="0"> <set value="25" /> <set value="25" /> <set value="16.66" /> <set value="21.05" /> <set value="6.66" /> <set value="33.33" /> <set value="6.25" /> <set value="25" /> <set value="5.88" /> <set value="36.36" /> <set value="10.52" /> <set value="30.43" /> </dataset> </chart> }); revenueChart.render(); }) </script> </head> <body> <div id="chartContainer">FusionCharts XT will load here!</div> </body> </html>
  6. Problem with multiple graphs

    Hi folks. I am experiencing problems creating a chart with more than one graphs from a php script. There are supposed to be three graphs in the chart but only one appears. Here's my XML data: <chart caption='15.01.2014 - 03.11.2014' subCaption='' showValues='0' useRoundEdges='1' showBorder='1' xAxisName='WoY' yAxisName='Revenue' decimals='2' formatNumberScale='0' numberSuffix=' €'> <categories> <category label='33' /> <category label='35' /> <category label='36' /> <category label='39' /> <category label='40' /> <category label='41' /> <category label='42' /> <category label='45' /> </categories> <dataset seriesname='Total'> <set value='1250.67' /> <set value='1522' /> <set value='150' /> <set value='195' /> <set value='470' /> <set value='300' /> <set value='1270' /> <set value='0' /> </dataset> <dataset seriesname='Old' color='008ee4'> <set value='500' /> <set value='1010' /> <set value='150' /> <set value='195' /> <set value='470' /> <set value='300' /> <set value='1270' /> <set value='0' /> </dataset> <dataset seriesname='New' color='008ee4'> <set value='750.67' /> <set value='512' /> <set value='0' /> <set value='0' /> <set value='0' /> <set value='0' /> <set value='0' /> <set value='0' /> </dataset> </chart> This XML data is stored in $strXML and FusionCharts is called like this: <script type="text/javascript" src="fusioncharts/js/themes/fusioncharts.theme.zune.js"></script> <script type="text/javascript"> FusionCharts.ready(function(){ var revenueChart = new FusionCharts({ "type": "line", "renderAt": "chartContainer", "width": "100%", "height": "400", "palette": "1", "dataFormat": "xml", "dataSource": "'.$strXML.'" }); revenueChart.render("chartContainer"); }); </script>'; The result can be seen in the attached PNG. What am I doing wrong? Thank you all very much in advance!
  7. Hello, I just started exploring FushionCharts XT today and curious is a routine in get current date to display in the xml chart subcaption property. This would be very useful display when printing multiple reports per customer. I realize will have to also create an element containing the customer id. Thanks Mactire
  8. Hi all! Any idea what this white box circled in this image is and how you format it (bg color etc)???? Only tried everything... Cheers, mark
  9. Hi guys, I have the following attributes in my chart's xml and many of them do not render for some reason: <chart dynamicAxis='1' toolbar='c0392b' toolbarButtonFontColor='FFFFFF' mouseCursorColor='c0392b' zeroPlaneColor='E51400' numDivLines='6' showAlternateHGridColor='0' numVDivLines= '10' showAlternateVGridColor='0' showVDivLines='1' showtooltip='1' showToolTipShadow='0' toolTipBorderColor='FFFFFF' toolTipBorderColor='FFFFFF' connectnulldata='1' compactdatamode='1' showLabels='1' baseFontColor ='FFFFFF' showBorder='0' bgColor='FFFFFF' bgAlpha='0' showYAxisValues='1' showXAxisValues='1' pixelsperpoint='15' drawToolbarButtons='1' dataseparator='|' drawAnchors='0' scrollColor='595959' scrollPadding='0' scrollBtnPadding='0' scrollChannelBorderColor='595959' scrollBtnArrowColor='595959' legendBgColor='FFFFFF' legendBgAlpha='0' legendBorderColor='FFFFFF' legendBorderThickness='0' legendShadow='0' legendAllowDrag='1' legendBorderAlpha='0' legendposition='BOTTOM' legendPadding='10' canvasBorderColor='34495e' canvasBorderThickness='1' canvasBgColor='FFFFFF' canvasbgAlpha='0' showCanvasBorder='1' chartTopMargin='10' canvasPadding='2' zoomPaneBgColor='FFFFFF' zoomPaneBgAlpha='10' > showVDivLines='1' ---> no vertical div lines canvasPadding='2' --->canvas padding is enormous toolbar='c0392b' ---> no change of color for the buttons zeroPlaneColor='E51400' ----> did turn red, then disappeared Any thoughts? Getting a bit frustrated :-) Cheers, Mark
  10. Transparent Loading

    Hi all, Simple one no doubt for the pros: I render my charts on a grey div background. Whilst they are loading, there are huge white gaps on the grey background. I like the data loading bar, just not the big white gaps... any way of making the canvas/ bg transparent from the very beginning? To be specific: I am rendering the graphs (guages, sparks, zoomline, maps) from data in a xml files individually generated by code in a php page, contained in a wordpress site, having tried all the forums and google, I have a glass of wine in my hand and I'm wearing jeans and a t-shirt. I also am not a big fan of fresh tomatoes, though mixed with some burrata and greek basil, I can be persuaded. MASSIVE fan of indian food. I could go on, though it's getting less and less relevant. Cheers! Mark
  11. This problem seems to have started about 30 days ago. We noticed that our 2D Stacked column charts stopped displaying subcaptions for Flash installations. The same charts have been running fine for 2 years and our other charts, like Pie Charts, are working fine. However, our 2d Stacked column charts will not display subcaptions when viewed with Flash. The same 2D Stacked Column charts work fine when viewed with jscript. We have noticed this with IE, Firefox and Chrome browsers.
  12. Back Button not working

    Hi All, I have integrated Fusion chart trail version to My cakephp project and I have passed the datas from database to fusion charts. Its working fine. But when I click on year which is goes to Month, In that I didn't get back button. How can I integrate the Back Button.Please advice me. Thanks in Advance.