Wmode=Transparent Not Rendering In Ie9

Recommended Posts

I am using FusionMaps in a page that also has <ajax:HoverMenuExtender> being used for navigation menus.


The issue we are having is that when our HoverMenus extend as they are supposed to, they appear behind the map.


This is simple enough to fix, as we can utilize the "WMode=Transparent" bit of code to get the .swf file to appear behind the HoverMenuExtenders.


That said, this does NOT work in Internet Explorer 9. This DOES work in Firefox 14.1, which our product also supports. This is clearly a problem with IE9, but I need to find a way around it.


Research has shown that adding a line of code into the JavaScript map rendering can fix it.


This is the javascript that FusionMaps is producing:


var Map_mapid = new FusionMaps("../FusionMaps/FCMap_WorldwithCountries.swf", "mapid", "800", "600", "0", "0");


I need to add a line of code that says:"-1"

or similar so I can push the .swf object to the back and allow our hovermenuextenders to show up above the FusionMap.


I am generally unskilled with using JavaScript (my coding experience is mostly in ASP.NET and C#), so I am not sure how to alter the FusionMaps.js file to add this line of code.



Can anybody help with this problem?

Edited by rockiesmagicnumber

Share this post

Link to post
Share on other sites
Guest Sumedh



Recently, we have released new version of FusionMaps i.e., FusionMaps XT v3.2. You can now render maps on devices where Flash player is not supported (like in iPhone/iPad), is not installed or is disabled.


For this, FusionMaps XT uses the built-in JavaScript rendering capabilities. The maps, rendered by this module, purely use JavaScript and do not need Flash Player at all.


For more information, please refer the following URL's:





For transparency, you would have to set allowTranparent property as "true" in the RenderChart method.


Also, set bgAlpha attribute as "0" under the map element in the XML. (<map ... bgAlpha="0">)


Ref. Code:


FusionCharts.RenderChart("Scripts/FCMap_World.swf", "MapData.xml", "", "myMapId", "600", "400", false,true, true);


For more information, please refer the following URL:



Hope this helps!

Share this post

Link to post
Share on other sites
Guest Sumedh

Thank you for your reply! I will work on installing the upgrade to FusionMaps XT and get back to this thread after I've done so.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now