Elger van Boxtel

Gantt: isUnderline property on WebKit browsers not working

Recommended Posts

Hi All!


I woud like to disable the underlining of Categories and Processes on the Gantt chart. Underlining should never occur, even not on mouse over.

For this, I've used the properry isUnderline on the <categories> and <processes> elements.


Apparently this works great on IE7+ and Firefox 23, but on WebKit browsers (like Chrome, Safari) this doesn't work as expected. Looks like this is a small bug in FusionCharts?


I've created a screenshot which clearly shows the problem:




Any help would be appreciated!

Share this post

Link to post
Share on other sites



The Gantt chart does not show an underline beneath the categories and processes by default. You may explicitly specify the same by setting "isUnderline" to '0' in categories and processes elements.


Ref. <categories isUnderline='0' ...>


The underline does not show up on categories and processes even on Chrome browser here. Could you please provide your XML so that we can check it too?


Awaiting your response.

Share this post

Link to post
Share on other sites

Hi Haritha,


Thanks for your quick answer.


I've found the problem. In my css I had a{text-decoration:underline;}, which overrules the FusionCharts setting on WebKit browsers. (In IE and FF these were rendered well).


Now I've added some css styling: #planboardID a{text-decoration:none;}, which solves my problem.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now