Sign in to follow this  

Ampersand in MSLine seriesName

Recommended Posts

Displaying ampersand as part of seriesName in fusions charts not working the same in IE as Firefox/Chrome.  (especially IE 8).  Attached are the relative outputs.  The short version is that IE is not displaying the Ampersand, or anything after, while in Firefox/Chrome, the Ampersand is showing appropriately.


Here's the XML:

<chart defaultAnimation='0' plotGradientColor=' ' showBorder='0' canvasBorderColor='A0A0A4' bgcolor='FFFFFF' canvasBorderThickness='1' canvasBorderAlpha='100' canvasbgColor='FFFFFF' canvasbgAlpha='0' canvasTopMargin='8' canvasBottomMargin='0' chartTopMargin='5' chartBottomMargin='0' chartLeftMargin='0' formatNumberScale='0' numDivlines='0' divLinecolor='969696' showLegend='1' legendCaption='' legendIconScale='1' legendPosition='RIGHT' legendBgColor='FFFFFF' legendBgAlpha='0' legendBorderColor='FFFFFF' legendBorderThickness='0' legendBorderAlpha='0' legendShadow='0' legendAllowDrag='0' interactiveLegend='1' legendNumColumns='1' minimiseWrappingInLegend='1' baseFont='Arial' baseFontSize='14' baseFontColor='000000' outCnvbaseFontSize='14' outCnvbaseFontColor='969696' showtoolTip='1' toolTipBorderColor='969696' toolTipBgColor='969696' xAxisName='' labelDisplay='Wrap' yAxisName='' showYAxisValues='1' yAxisMinValue='-50' yAxisMaxValue='50' numberSuffix='%'>  <categories>  <category label='W1' tooltext='Wave 1'/>  </categories>  <dataset seriesName='AAAA' color='#B00000' anchorSides='4' anchorRadius='4' >  <set value='40' showValue='0'  />  </dataset>  <dataset seriesName='AA&A' color='#B2B2B2' anchorSides='4' anchorRadius='4' >  <set value='22' showValue='0'  />  </dataset>  <dataset seriesName='AAAA' color='#7F7F7F' anchorSides='4' anchorRadius='4' dashed='1' lineDashLen='1'>  <set value='19' showValue='0'  />  </dataset>  <dataset seriesName='AAAA' color='#595959' anchorSides='4' anchorRadius='4' dashed='1' lineDashLen='2'>  <set value='24' showValue='0'  />  </dataset>  <dataset seriesName='EEEE' color='#404040' anchorSides='4' anchorRadius='4' dashed='1' lineDashLen='3'>  <set value='47' showValue='0'  />  </dataset> <styles> <definition> <style name='MSTitle' type='font' size='12' color='1B1E1A' /> <style name='MSSubTitle' type='font' size='10' color='969696' /> <style name='Stubs' type='font' size='11' color='1B1E1A' /> <style name='Data' type='font' size='11' color='1B1E1A' /> <style name='RollOver' type='font' size='10' color='FFFFFF' /> <style name='AxisLabels' type='font' size='9' color='969696' /> </definition> <application> <apply toObject='caption' styles='MSTitle' /> <apply toObject='subcaption' styles='MSSubTitle' /> <apply toObject='DataLabels' styles='Stubs' /> <apply toObject='DataValues' styles='Data' /> <apply toObject='Legend' styles='Data' /> <apply toObject='toolTip' styles='RollOver' /> <apply toObject='yAxisValues' styles='AxisLabels' /> </application> </styles> </chart>

We've tried many different replacements for the Ampersand, but none of them worked in both places:

  1. &
  2. &amp;
  3. %26
  4. &
  5. &%26;
  6. &#x26; - This worked in IE, but broke in Firefox & chrome

So, how can we consistently have an Ampersand displayed in the labels for an MSLine chart?



Share this post

Link to post
Share on other sites
Guest Rishab


Please let me know the FusionCharts XT version you are using at your end.

I am unable to replicate the issue at my end.

The attached items are the screenshots of the JavaScript and Flash charts rendered by the data you provided using current version of FusionCharts XT suite.




Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this