Annotation hidden behind chart elements

Recommended Posts

When using column charts (column2d) and adding a callout annotation, the annotation is hidden behind other columns. (i.e. a lower stacking order).

Example: given the fiddle http://jsfiddle.net/fusioncharts/bLxr4/  change the value for Q1 to 40000. The column for Q1 now appears on top of the annotation.

(Note this also happens with line charts but is obviously more noticeable with columns.)

{FC XT 3.12}




Edited by James_UK

Share this post

Link to post
Share on other sites

Hi James,


FusionCharts provides the option to show the custom Annotations on the chart both in foreground as well as in background.

You need to set the group-level attribute "showBelow" to "0" to display the annotation on top always.

Check the modified fiddle : http://jsfiddle.net/Akash008/3jd9kq6q/

Please find the link below for further reference to configure annotations :





Share this post

Link to post
Share on other sites

Thanks Akash. I missed that setting, or more accurately I didn't understand what the Description meant.

Perhaps you could change the following page as well to reflect the change you made on the grouping-annotations.html page?



Thanks for your quick reply and your help.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now