Ashish_R

Members
  • Content count

    4
  • Joined

  • Last visited

Everything posted by Ashish_R

  1. Export Not Working In Ie

    Hi everybody, I recently upgraded to Fusion charts XT and am seeing a problem with export in IE. Export seems to be working just fine in other browsers like FF and Chrome but IE doesn't seem to be showing the export options although XML used has the export options configured and is the same for other browsers and IE. It seems like IE is caching and is using old swf files as the legends displayed are different in different browsers. I have tried refreshing ctrl+F5 and used developer tools to clear the cache in IE but it doesn't seem to work. Following is the XML that is used. Any help is greatly appreciated. <chart borderThickness="0" showBorder="0" bgAlpha="0,0" plotGradientColor="4F7DAC" caption="Unscheduled Work Orders - All Stations - Weekly" xAxisName="Date Range" yAxisName="Unscheduled Work Orders - All Stations" showValues="0" labelStep="2" labelDisplay="Rotate" slantLabels="1" exportEnabled="1" exportAtClient="1" exportHandler="fcExporter100057" exportShowMenuItem="1" exportFileName="Unscheduled Work Orders - All Stations" exportFormats="PNG=Export as High Quality Image|JPG=Export as image|PDF=Export as PDF File"> <categories> <category label="2012.07.09" /> <category label="2012.07.16" /> <category label="2012.07.23" /> <category label="2012.07.30" /> <category label="2012.08.06" /> <category label="2012.08.13" /> <category label="2012.08.20" /> <category label="2012.08.27" /> <category label="2012.09.03" /> <category label="2012.09.10" /> <category label="2012.09.17" /> </categories> <dataset seriesName="Location1" color="52ADC6"> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> </dataset> <dataset seriesName="Location2" color="9CBD52"> <set value="1" /> <set value="1" /> <set value="1" /> <set value="1" /> <set value="1" /> <set value="1" /> <set value="1" /> <set value="1" /> <set value="1" /> <set value="1" /> <set value="1" /> </dataset> <dataset seriesName="Location3" color="948C52"> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> </dataset> <dataset seriesName="Location4" color="7B5A8C"> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> </dataset> </chart>
  2. we recently upgraded to Fusion charts XT and looks like the first label in 2D line chart gets mangled up in the new version. Please take a look at the first date label in the attached files which is supposed to be 2012.07.16. Following is the XML being used. <chart borderThickness="0" showBorder="0" bgAlpha="0,0" plotGradientColor="4F7DAC" caption="Rework Orders - All Stations # - Weekly" xAxisName="Date Range" yAxisName="Rework Orders - All Stations #" showValues="0" labelStep="2" labelDisplay="Rotate" slantLabels="1"> <categories> <category label="2012.07.16" /> <category label="2012.07.23" /> <category label="2012.07.30" /> <category label="2012.08.06" /> <category label="2012.08.13" /> <category label="2012.08.20" /> <category label="2012.08.27" /> <category label="2012.09.03" /> <category label="2012.09.10" /> <category label="2012.09.17" /> <category label="2012.09.24" /> </categories> <dataset seriesName="Station1" color="52ADC6"> <set value="0" /> <set value="0" /> <set value="1" /> <set value="1" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="1" /> <set value="0" /> <set value="0" /> <set value="1" /> </dataset> <dataset seriesName="Station2" color="9CBD52"> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="1" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> </dataset> <dataset seriesName="Station3" color="948C52"> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> </dataset> <dataset seriesName="Station4" color="7B5A8C"> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> <set value="0" /> </dataset> </chart> Before: After upgrading to XT:
  3. Labels Getting Mangled In Fusion Charts Xt

    Thanks for the reply. I used the canvasPadding attribute and like you said, the charts didn't start from the origin. We are using this chart on a page where there are multiple other charts as well and this issue is seen with most of them. I changed their dimensions and we ended up with a pretty wide and tall webpage where the users would have to scroll down to see some of the charts. Is there anyway to just get the older label functionality back where the dates weren't skewing and the Y-axis and the X-axis labels weren't overlapping?
  4. Labels Getting Mangled In Fusion Charts Xt

    I set that flag and looks like it fixed the mangled label but now the label on the Y-axis is overlapping with that label. Please see the screenshot. How do I fix this? Hi, Please note that this is the advanced label management feature of the FusionCharts XT. However, you can disable the XT label management option by setting "xtLabelManagement" to '0' in the <chart> element of the XML. Hope this helps.