Alexander87

Chart Area Show Problem

Recommended Posts

Hello,

 

I have a problem with my area charts.

in my xml file is 0 value but on the chart appear that I have a value.

 

The XML file is:

<chart caption='Débit' subCaption='1 mois' labelStep='2' labelDisplay='WRAP' numdivlines='9' lineThickness='1' showValues='0' chartRightMargin='30' numVDivLines='22' formatNumberScale='0' anchorAlpha='0' useRoundEdges='1' exportAction='save' exportAtClient='0' exportEnabled='1' exportFileName='chartAnalyseCapture' exportShowMenuItem='0' exportDialogMessage='Export statut: ' exportHandler='../../FCExporter' exportCallback='FC_Exported'  animation='1' limitsDecimalPrecision='0' divLineDecimalPrecision='1' connectNullData='1'  yAxisName='l' >
<categories>
<category label='01/07/2010 00:00'/>
<category label='01/08/2010 00:00'/>
<category label='01/09/2010 00:00'/>
<category label='01/10/2010 00:00'/>
<category label='01/11/2010 00:00'/>
<category label='01/12/2010 00:00'/>
<category label='01/01/2011 00:00'/>
<category label='01/02/2011 00:00'/>
<category label='01/03/2011 00:00'/>
<category label='01/04/2011 00:00'/>
<category label='01/05/2011 00:00'/>
<category label='01/06/2011 00:00'/>
<category label='01/07/2011 00:00'/>
<category label='01/08/2011 00:00'/>
<category label='01/09/2011 00:00'/>
</categories>
<dataset seriesName='CPT 007A' color='#FF8000'  renderAs='Area' >
<set value='0.0'  tooltext = 'CPT 007A, 01/07/2010 00:00:00, vide' />
<set value='0.0'  tooltext = 'CPT 007A, 01/08/2010 00:00:00, vide' />
<set value='0.0'  tooltext = 'CPT 007A, 01/09/2010 00:00:00, vide' />
<set value='3.0'  tooltext = 'CPT 007A, 01/10/2010 00:00:00, 3,00 l' />
<set value='0.0'  tooltext = 'CPT 007A, 01/11/2010 00:00:00, vide' />
<set value='1.0'  tooltext = 'CPT 007A, 01/12/2010 00:00:00, 1,00 l' />
<set value='-3.5'  tooltext = 'CPT 007A, 01/01/2011 00:00:00, -3,5000 l' />
<set value='0.0'  tooltext = 'CPT 007A, 01/02/2011 00:00:00, 0,0000 l' />
<set value='0.0'  tooltext = 'CPT 007A, 01/03/2011 00:00:00, vide' />
<set value='0.0'  tooltext = 'CPT 007A, 01/04/2011 00:00:00, vide' />
<set value='0.0'  tooltext = 'CPT 007A, 01/05/2011 00:00:00, vide' />
<set value='0.0'  tooltext = 'CPT 007A, 01/06/2011 00:00:00, vide' />
<set value='0.0'  tooltext = 'CPT 007A, 01/07/2011 00:00:00, vide' />
<set value='0.0'  tooltext = 'CPT 007A, 01/08/2011 00:00:00, vide' />
<set value='0.0'  tooltext = 'CPT 007A, 01/09/2011 00:00:00, vide' />
</dataset>
<dataset seriesName='Eau_2' color='#0000FF'  renderAs='Area' >
<set value='0.0'  tooltext = 'Eau_2, 01/07/2010 00:00:00, vide' />
<set value='0.0'  tooltext = 'Eau_2, 01/08/2010 00:00:00, vide' />
<set value='0.0'  tooltext = 'Eau_2, 01/09/2010 00:00:00, vide' />
<set value='0.0'  tooltext = 'Eau_2, 01/10/2010 00:00:00, vide' />
<set value='0.0'  tooltext = 'Eau_2, 01/11/2010 00:00:00, vide' />
<set value='0.0'  tooltext = 'Eau_2, 01/12/2010 00:00:00, vide' />
<set value='0.0'  tooltext = 'Eau_2, 01/01/2011 00:00:00, vide' />
<set value='0.0'  tooltext = 'Eau_2, 01/02/2011 00:00:00, vide' />
<set value='0.0'  tooltext = 'Eau_2, 01/03/2011 00:00:00, vide' />
<set value='0.0'  tooltext = 'Eau_2, 01/04/2011 00:00:00, vide' />
<set value='0.0'  tooltext = 'Eau_2, 01/05/2011 00:00:00, vide' />
<set value='0.0'  tooltext = 'Eau_2, 01/06/2011 00:00:00, vide' />
<set value='0.0'  tooltext = 'Eau_2, 01/07/2011 00:00:00, vide' />
<set value='0.0'  tooltext = 'Eau_2, 01/08/2011 00:00:00, vide' />
<set value='5.0'  tooltext = 'Eau_2, 01/09/2011 00:00:00, 5,00 l' />
</dataset>
<styles><definition><style name='myToolTipFont' type='font' font='Verdana' size='12' color='000000' isHTML='1'/></definition><application><apply toObject='ToolTip' styles='myToolTipFont'/></application></styles></chart>

 

 

and the chart is attached image.

 

can you help me.

 

Thank you.

post-19556-0-70502100-1311586680_thumb.png

post-19556-0-38249600-1311586843_thumb.png

post-19556-0-64043900-1311587615_thumb.png

Edited by Alexander87

Share this post


Link to post
Share on other sites
Guest Angshu

Hi,

 

Welcome to FusionCharts Forum!smile.gif

 

It seems from your XML code that the data you have sent is not matching with the screenshot.

 

For ex: 'Eau_2, 01/12/2010 00:00:00, vide' is not the correct anchor tool text.

 

Please send us the valid XML code to test it from our end.

 

Awaiting for your response.

Share this post


Link to post
Share on other sites

Hi,

 

The XML is the valid, I don't know what happen.

 

The last image with the line chart is just an example where it works. The problem is just for area, because I use also pie and bar and no problems.

 

I use FusionCharts with Java.

I can use also without any tooltext:

 

<chart caption='Débit' subCaption='1 mois' labelStep='2' labelDisplay='WRAP' numdivlines='9' lineThickness='1' showValues='0' chartRightMargin='30' numVDivLines='22' formatNumberScale='0' anchorAlpha='0' useRoundEdges='1' formatNumber='0' exportAction='save' exportAtClient='0' exportEnabled='1' exportFileName='chartAnalyseCapture' exportShowMenuItem='0' exportDialogMessage='Export statut: ' exportHandler='../../FCExporter' exportCallback='FC_Exported'  animation='1' limitsDecimalPrecision='0' divLineDecimalPrecision='1' yAxisName='l' >
<categories>
<category label='01/07/2010 00:00'/>
<category label='01/08/2010 00:00'/>
<category label='01/09/2010 00:00'/>
<category label='01/10/2010 00:00'/>
<category label='01/11/2010 00:00'/>
<category label='01/12/2010 00:00'/>
<category label='01/01/2011 00:00'/>
<category label='01/02/2011 00:00'/>
<category label='01/03/2011 00:00'/>
<category label='01/04/2011 00:00'/>
<category label='01/05/2011 00:00'/>
<category label='01/06/2011 00:00'/>
<category label='01/07/2011 00:00'/>
<category label='01/08/2011 00:00'/>
<category label='01/09/2011 00:00'/>
</categories>

<dataset seriesName='CPT 007A' color='#FF8000'  renderAs='Area' >
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='3.0' />
<set value='0.0' />
<set value='1.0' />
<set value='-3.5' />
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
</dataset>

<dataset seriesName='Eau_2' color='#0000FF'  renderAs='Area' >
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='0.0' />
<set value='5.0' />
</dataset>

<styles>
<definition>
<style name='myToolTipFont' type='font' font='Verdana' size='12' color='000000' isHTML='1'/>
</definition>
<application>
<apply toObject='ToolTip' styles='myToolTipFont'/>
</application>
</styles>
</chart>

 

 

and the generated chart are the same.

some overlap appear because Eau_2 has just one value ,5.

 

Thanks,

 

Alex

Share this post


Link to post
Share on other sites
Guest Angshu

Hi,

 

Thanks for your reply.

 

Could you please elaborate your query a bit more?

 

By default, tool tip will be displayed in FusionCharts.

 

In case you have any other issue, please clarify.

 

Awaiting for your response.

Share this post


Link to post
Share on other sites

Hi,

In JavaScript I thing there are no problems because I use 4 types of charts and just Area doesn't work.

Anyway I put, if is usefull for you, JavaScript code for creating chart.

 


function reloadAnalyseChartForTypeMeter(divToRender, width, height) {
   document.getElementById(divToRender).value = '';
   document.getElementById(divToRender).innerHTML = '';
   document.getElementById(divToRender).style.display = 'inline';

   var curveRadios1 = Ext.getCmp('chooseCurbesOnChart').getValue();
   var curveRadios2 = Ext.getCmp('chooseCurbesOnChart2').getValue();
   var chartSWF = "MSCombiDY2D.swf";
   if (curveRadios1) {
       var selectedChartType = document.getElementById('hiddenTypeOfChart').value;
       if (curveRadios1 == noneCurve && curveRadios2 == noneCurve) { 
           if (selectedChartType == bar) {
               chartSWF = "StackedColumn2D.swf";
           } else if (selectedChartType == line) {
               chartSWF = "MSLine.swf";
           } else if (selectedChartType == pie) {
               chartSWF = "Pie2D.swf";
           } else if (selectedChartType == radar) {
               chartSWF = "Radar.swf";
           } else if (selectedChartType == area) {
               chartSWF = "StackedArea2D.swf";
           }
       }
}
   chartAnalyse = new FusionCharts("/fusioncharts/" + chartSWF, "chartAnalyseId", width, height, "0", "1");
   chartAnalyse.setDataXML(document.getElementById('sourceAnalyseTypeMeter').value);
   chartAnalyse.render(divToRender);
}

 

and "sourceAnalyseTypeMeter" is a String with XML value.

 

and this function is called from:

 

reloadAnalyseChartForTypeMeter('chartDivTypeMeterAnalyse', 650, 500);

 

and the render div is:

 

<t:div id="chartDivTypeMeterAnalyse" style="width:100%;align:center" forceId="true" />

 

 

 

I don't know if are some problems here.

I was thinking if are some properties or attributes for area chart, because that chart show values in a place where I don't have anything.

Eau_2 copy some part of chart CPT 007A.

Thanks for help,

 

Alex

Share this post


Link to post
Share on other sites

Hi,

 

I found the problem, laugh.gif

In fact, it wasn't any problem angry.gifangry.gif. Was a normal behavior of Stacked Area 2D chart, because from a value of the other chart it goes to 0 and must fill the space.

So I choose to use MSArea chart. biggrin.gifbiggrin.gifbiggrin.gif. And now it works fine. cool.gifcool.gifcool.gif.

Thanks for help,

Alex

post-19556-0-96915100-1311685694_thumb.png

Share this post


Link to post
Share on other sites
Guest Angshu

Hi,

 

Glad to know that you have managed to resolve your problem.

 

Happy FusionCharting!biggrin.gif

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now