Gantt scrollbars render poorly on touch-enabled laptops

Recommended Posts

On touch-enabled Windows 10 laptops, the Gantt scrollbars render with a 4px border (stroke-width) when the scrollbar is narrow.  For example, if you go to and remove the "theme" setting from the config, the vertical scrollbar shows the issue on such machines:


If you change the scrollHeight in the config to 11, the horizontal scrollbars will appear the same way.  The behavior occurs on both Chrome and FireFox.  In FireFox, if we apply the workaround mentioned in this topic:, the scrollbars render correctly (the same way they render on non-touch enabled machines).  Our preference would be to have the scrollbars render the same on both touch and non-touch machines.  However, if that is not possible, could you have the vertical scrollbar use the scrollHeight setting or provide something like a verticalScrollWidth setting that would render correctly using a value of 20 (for example)?


Share this post

Link to post
Share on other sites

Thanks for the suggestion, but we need the default behavior, as described here:

"Vertical scrolling is enabled by default depending on the height of the chart. If the number of processes fit within the height of the chart, vertical scrolling will not appear."

This rendering issue did not exist in 3.8.0.  It only appeared once we attempted to upgrade to 3.12.2.  Please provide a fix.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now