Recommended Posts

I have updated window 10 server 2012 R2 and also java from 1.7 to 1.8.

After update i'm able to show chart  but when drill down to next level getting below mentioned error.

Error:

script5007: unable to get property 'push' of undefined or null reference in fusionchart.hc.js 

found line which include error on console of browser (checked in chrome, IE11 and mozila same error in all the browsers):

.push({cmd:"render",obj:this,args:arguments}) in fusionchart.hc.js file.

Edited by Brajesh Kourav
Detailed out.

Share this post


Link to post
Share on other sites

Hi Brajesh,

 

The JS file fusionchart.hc.js file was used long back which has been deprecated now.

FusionCharts current version is 3.13.1, and there has been huge architectural changes made along with new features and chart types added to the library. We would suggest you to upgrade to the current version and check.

Download link(Trial version) 3.13.1 : https://www.fusioncharts.com/download/fusioncharts-suite

DevCenter link : https://www.fusioncharts.com/dev/

 

Thanks,

Akash.

Share this post


Link to post
Share on other sites
9 minutes ago, Akash Biswas said:

Hi Brajesh,

 

The JS file fusionchart.hc.js file was used long back which has been deprecated now.

FusionCharts current version is 3.13.1, and there has been huge architectural changes made along with new features and chart types added to the library. We would suggest you to upgrade to the current version and check.

Download link(Trial version) 3.13.1 : https://www.fusioncharts.com/download/fusioncharts-suite

DevCenter link : https://www.fusioncharts.com/dev/

 

Thanks,

Akash.

Hello Akash,

First of all thanks for your reply.

When i'm using this fusion chart in my local system with window 7 it is working fine with all level and also on prod server with window 10 it shows first chart but after drill down to next level it is showing mentioned error on prod server.

So please clarify on this that i need to change fusionchart.hc.js for windows 10 update right?

Note : Is it fusionchart OS/browser dependent or not please clarify the version compatibility for fusion chart (for OS and browser).

 

Share this post


Link to post
Share on other sites

Hi Brajesh,

 

FusionCharts is not browser or OS dependent. It will work across all browsers and OS.

You need to use the current version library and check if you are getting the issue, as the version that you are using is deprecated and support has been discontinued for that version.

 

Thanks,

Akash.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now